Jump to content
texevora

Constant AIM Solo2 issues (vs trouble-free Solo)?

Recommended Posts

Curious if anyone else has upgraded from the AIM Solo to the Solo2 and has had a similar experience to mine?

I upgraded from a SoloDL to a Solo2 DL in March (about 6 months ago), and have had nothing but constant issues with the Solo2. I'm getting useless/nonsensical/inaccurate g-force data from the Solo2. This is even after having to send my Solo2 in for service due to it constantly losing GPS accuracy mid-session and stopping both lap-timing and predictive timing. AIM fixed the timing issue by replacing the GPS antenna, however my Solo2's g-force data (both internal accelerometers & GPS-derived g-force data) is either completely nonsensical on the internal accelerometers, or super "jaggy" and all over the place for the GPS-derived data. This makes it impossible to do any sort of relative analysis.

I feel like I either have a lemon of a Solo2 unit, or the Solo2's are just inherently problematic vs the Solos. I had no issues with my Solo in several years of ownership, and it's super-frustrating wasting testing session after testing session with the Solo2 collecting what ends up being useless g-force data. 

Any thoughts/suggestions welcome.

Link to post
18 hours ago, N546RV said:

I can't offer anything other than a data point: I bought my Solo 2 DL late last year, and it's worked perfectly for me, no issues whatsoever.

Ditto. Sorry you guys are having trouble. 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...